Change page style: 

Requirements for running the Gemini IRAF package

The Gemini IRAF package is an external package layered upon IRAF. Therefore, anyone wishing to use the Gemini IRAF package must first install IRAF. All users are encouraged to use Ureka to install IRAF and the Gemini IRAF package. Ureka contains a modified version of the 32-bit version of IRAF v2.16 with bug fixes specific to the Gemini IRAF package. Please see the download page for specific information about installing the Gemini IRAF package using Ureka.

Requirements for non-Ureka users

For those users who do not wish to use Ureka, the requirements for the Gemini IRAF package are listed below.

The Gemini IRAF package has been tested under IRAF v2.14.1. The minimum requirement is IRAF v2.14.1. The Gemini IRAF package will not work properly under any earlier versions of IRAF. Please note that the Gemini IRAF package does NOT work reliably with the 64-bit version of IRAF v2.15 or with the 32-bit or 64-bit version of IRAF v2.16 as distributed by NOAO.

The Gemini IRAF package requires that a number of other external IRAF packages are installed. The Gemini IRAF package will not load if any of these external packages are missing. These packages are listed in the table below.

Package name Recommended Version Comments
For all users
stsdas 3.15 Distributed by Space Telescope Science Institute
tables 3.15 Distributed by Space Telescope Science Institute
For IRAF v2.14 users
fitsutil December 5, 2005 Distributed by IRAF, hosted by Gemini
For IRAF v2.15 users
fitsutil March 27, 2011 Distributed by IRAF
Optional, if PyRAF is desired
stsci_python 2.12 Distributed by Space Telescope Science Institute
PyRAF 1.11 Distributed by Space Telescope Science Institute; included in the stsci_python distribution; for IRAF v2.15 users, v1.11 of PyRAF is required

It is also required that one of the following image display tools is available: ximtool, SAOimage, SAOtng or ds9.

The official pre-release testing was done using 32-bit binaries on a 64-bit machine running a 64-bit Redhat Enterprise Linux 5 OS. The Gemini IRAF package is distributed with 32-bit binaries for Linux Redhat 9.0/Fedora Core 4 (compatible with RHEL and later versions of Fedora), and Mac OS X 10.6 Intel, compatible with Mac OS X 10.7 Intel and Mac OS X 10.8 Intel. For other 32-bit architectures, new binaries have to be compiled. Please see the installation instructions for more details.