QPT Reference Manual

This is interim reference documentation for Gemini QPT version 1.0.5

This documentation is intended for Gemini queue coordinators and others who are generally familiar with the way things work at Gemini. It is not intended for external distribution and at this time likely contains errors and omissions.

Overview

QPT is a Java-based desktop application that allows queue coordinators to produce nightly observing plans using a visual drag-and-drop interface. QPT performs all the routine constraint calculations automatically, allowing the user to build high-quality plans confidently, without worrying about things like accidentally pointing at the moon.

Constructed plans are published to the internal webserver for use by nightly observers.

Concepts

This section introduces concepts and terminology that you will need to understand in order to make sense of the rest of this document. It goes into more detail than you probably need right now, but skim it anyway.
Plans and Instrument Configurations

QPT constructs an observing plan for a specific night. Multi-night plans are not supported (yet). Each plan specifies the set of instruments* (and configurations in the case of instruments with changeable components) that will be available.

QPT saves each plan as a single XML file that has no other dependencies and may be shared like any other file.

QPT publishes plans directly to the internal webserver as HTML documents with elevation charts.

*It is likely that this terminology will change to system or something like that, because some of the items in the instrument list (such as Altair and GCAL) are not really instruments.

Variants

Each Plan consists of one or more Plan Variants. A variant represents a plan contingency for a particular set of environmental conditions (such as CC = 50% /IQ = 20% / WV = 50%). By default a new plan will contain eleven common variants, although the user may edit these freely.

At any time, only one variant is active in QPT. This is the current variant.

Candidate Observations and Observation Flags

Each plan has a set of candidate observations that are available for scheduling. An observation is included in this set if all of the following conditions apply:

- The science program must be incomplete (i.e., not marked complete).
- The science program must be of type Q, C, SV, DD, or DS.
- The science program must be assigned to the current semester (based on the UT date of the plan) or must be a rollover program from either of the two preceding semesters. Additional semesters may be added via the Add Semester command described below.
- The science program must have a numeric science band.
- The observation must be a partner calibration, program calibration, or a science observation.
- The observation's status must be READY or ONGOING.
- The observation must have at least one unexecuted sequence step.

QPT displays the list of candidate observations, filtered and decorated based on the plan and current variant.

<table>
<thead>
<tr>
<th>Candidate Observations</th>
<th>Score</th>
<th>Observation</th>
<th>Target</th>
<th>RA</th>
<th>Inst</th>
<th>Dur</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 H 1875</td>
<td>S06A-OD-17 [18]</td>
<td>r0ph12</td>
<td>16:22:30</td>
<td>CNRS</td>
<td>1:20:00</td>
<td></td>
</tr>
<tr>
<td>1 H 1875</td>
<td>S06A-OD-17 [26]</td>
<td>r0ph12</td>
<td>16:22:30</td>
<td>CNRS</td>
<td>1:00:00</td>
<td></td>
</tr>
<tr>
<td>1 H 1500</td>
<td>S06A-OD-2 [2]</td>
<td>SMC2</td>
<td>0:42:47</td>
<td>CNRS</td>
<td>1:40:00</td>
<td></td>
</tr>
<tr>
<td>1 H 1500</td>
<td>S06A-OD-3 [247]</td>
<td>J1427+0121</td>
<td>14:27:58</td>
<td>CNRS</td>
<td>0:40:00</td>
<td></td>
</tr>
<tr>
<td>2 H 750</td>
<td>S06A-OD-33 [8]</td>
<td>q2206-BX102</td>
<td>22:08:50</td>
<td>CNRS</td>
<td>1:20:00</td>
<td></td>
</tr>
<tr>
<td>2 H 375</td>
<td>S06A-OD-33 [37]</td>
<td>q2343-BX513</td>
<td>23:46:09</td>
<td>CNRS</td>
<td>2:20:00</td>
<td></td>
</tr>
<tr>
<td>3 H 166</td>
<td>S06A-OD-46 [94]</td>
<td>Source 5 - 3:32 ... 3:32:13</td>
<td>CNRS</td>
<td>1:40:00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3 H 166</td>
<td>S06A-OD-67 [66]</td>
<td>UDF-2</td>
<td>3:32:14</td>
<td>CNRS</td>
<td>1:20:00</td>
<td></td>
</tr>
<tr>
<td>3 L 133</td>
<td>S06A-OD-66 [52]</td>
<td>NGC 4697 SW2 ... 12:48:08</td>
<td>CMOS-S</td>
<td>0:22:53</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3 L 160</td>
<td>S06A-OD-66 [51]</td>
<td>NGC 4697, cent... 18:45:06</td>
<td>CMOS-S</td>
<td>0:22:53</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1 H 0</td>
<td>S06A-OD-10 [18]</td>
<td>HIP 59093</td>
<td>12:07:05</td>
<td>TRcS</td>
<td>1:22:54</td>
<td></td>
</tr>
</tbody>
</table>

Candidate observations are analyzed and given a set of flags that reflect the observations' suitability for scheduling in the currently-selected variant. The color and icon decorations in the Candidate Observations view are determined based on the "worst" of the present flags. Following are descriptions of all supported flags.

The following flags are intrinsic properties of the observation and do not depend on anything that happens within QPT. They will be the same in all variants on all nights.

- **INACTIVE** indicates that the observation belongs to an inactive science program. These observations are rendered in light gray.
• **IN_PROGRESS** indicates that the observation's status is "In Progress", normally meaning that one or more steps has been executed but the observation is not yet complete. Icons for these observations are decorated with a green "Play Button".

• **OVER_ALLOCATED** indicates that the program has no remaining time.

• **SCHED_GROUP** indicates that the observation is part of a scheduling group.

The following flags are influenced by the currently available set of instruments and configurations, and will be the same in all variants. Selecting and de-selecting items in the Instruments view can cause these flags to change.

• **INSTRUMENT_UNAVAILABLE** indicates that a required instrument is not available. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **CONFIG_UNAVAILABLE** indicates that the required instrument is available but the desired configuration option is not. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

The following flags are influenced by the current variant's site conditions, and will differ from variant to variant. Editing a variant's site conditions can cause these flags to change.

• **CC_UQUAL** indicates that the variant's cloud cover condition isn't restrictive enough for this observation. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **WV_UQUAL** indicates that the variant's water vapor condition isn't restrictive enough for this observation. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **IQ_UQUAL** indicates that the variant's image quality condition isn't restrictive enough for this observation. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **OVER_QUALIFIED** indicates that the variant conditions are better than required. The observation is rendered in dark gray with a slightly faded out icon.

The following flags are influenced by the targets' positions on the given night, and will be the same in all variants.

• **SETS_EARLY** indicates that the target sets below its elevation constraint during the first three hours of the night.

• **BACKGROUND_CNS** indicates that the observation's sky brightness constraint cannot be satisfied. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **ELEVATION_CNS** indicates that the observation's elevation (airmass or hour angle) constraint cannot be satisfied. The observation is rendered in light gray and the icon is decorated with a diagonal slash.

• **TIMING_CNS** indicates that the observation's timing window constraint(s) cannot be satisfied. The observation is rendered in light gray and the icon is decorated with a diagonal slash.
- **MULTI_CNS** indicates that although all constraints can be satisfied, they can't be satisfied at the same time (long enough to execute at least the first sequence step). The observation is rendered in light gray and the icon is decorated with a diagonal slash.

The following flags are influenced by the current state of a variant's list of scheduled visits. Adding, removing, or rearranging visits can cause these flags to change.

- **SCHEDULED** indicates that the observation appears on the visualizer and in the list of scheduled visits. The observation's icon is decorated with a little blue and white clock, and the observation is no longer draggable.

- **BLOCKED** indicates that the observation is schedulable (at least the first step), but only if you move something out of the way. The observation is rendered in light gray.

- **SETUP_BLOCKED** is a corner case and indicates that at least the first step of the observation is schedulable, but only if you skip the setup (possible if some cases). **PARTIALLY_BLOCKED** indicates that the observation is schedulable, but not the entire sequence.

**Visits and Problems**

A visit is a scheduled observation or portion thereof. More precisely, a visit is a span of sequence steps scheduled to begin at a specific time in a specific variant. An observation is normally scheduled as a single visit, but may be split into multiple visits in the same night or across several nights.

A visit may have **problems**, which are indicated by color coding in the Schedule Visualizer and by decorations on the observation's icon in the Scheduled Visits view. Errors normally indicate constraint violations (sky too bright, airmass too high, etc.) and are drawn in red. Warnings normally indicate that an error condition could arise if the observer falls behind schedule.

**Comments**
QPT allows the user to attach a comment to the top level of the plan, to each variant, and to each visit. These comments are arbitrary HTML text and will appear verbatim in the published plan.

**Menu Command Highlights**

**File > New Plan...**

This command closes the current plan if one is open (prompting to save if needed, etc.) and displays the New Plan dialog.

To create a new plan, select the site and the night for the new plan (tonight is chosen by default).

If you wish base this plan on another plan (normally last night's), click the Template button and select the QPT file that you wish to use as a template. The new plan will be constructed based on the template as follows:

- Variants, instruments/configurations, and comments will be copied over directly.
- All visits will be moved forward such that they will appear at the same distance from sunset.
- A Refresh operation will be performed (see below).

**File > Open...**

This behaves as expected, but note that it performs a Refresh operation (see below) after opening the plan.

**File > Open from Web...**

This command opens a plan by fetching its plan from the web server rather than by opening a local QPT file. It brings up a dialog similar to the New Plan dialog to allow you to select a date. Otherwise it is identical to the normal Open command. This command is half-baked and needs to be improved.

**File > Publish...**

This command publishes the current plan as an HTML document.
QPT first writes the plan document to temporary storage. If you have chosen "Preview Locally," the local plan document will be opened in your web browser. If you have selected "Publish to the Web," the plan will be copied to internal.gemini.edu and the published plan will be opened in your web browser. You will not be warned if you are about to overwrite an existing plan; this command assumes you know what you are doing.

View Menu
The View menu allows you to filter the candidate observations you see in the Candidate Observations view. The following filters are based directly on the flags described above. If any of the following flags are present, the observation will be hidden unless the flag is checked in the View menu. It makes more sense than you might think at this point.

- Over-Qualified (selected by default)
- Blocked (selected by default)
- Under-Qualified
- Unavailable Inst/Config
- Unschedulable
- Not Dark Enough
- Low in Sky

The remaining filters are based on intrinsic properties of the observations' science programs and should be fairly obvious.

- Inactive Programs
- Science Observations (selected by default)
- Calibration Observations
- Science Band 1 (selected by default)
- Science Band 2 (selected by default)
- Science Band 3 (selected by default)
- Science Band 4

Tools > Shorter / Longer / Maintain Spacing
These commands allow you to make a visit longer or shorter by adding or removing sequence steps from the plan, with the following constraints:

- The first visit to an observation must begin with the first unexecuted sequence step.
- A subsequent visit must continue where the preceding one left off.
- A visit must always contain at least one step.
- A visit may not continue past the end of the sequence.

The Longer / Shorter commands will preserve these constraints if possible, and will become disabled if this is not possible. If a non-terminal visit is made longer or shorter, steps will be
taken from or added to the subsequent visit. By default the spacing between visits is preserved when this happens; this is the most natural behavior. This behavior can be turned off by de-selecting the Maintain Spacing option. It's easier to just play with it than for me to explain it.

Tools > Split / Join
Any visit with more than one scheduled step may be split into two (or more) smaller visits. This is sometimes necessary in order to account for re-acquisition (the setup time re-appears in each sub-visit) or in order to "sneak in" another observation in the middle. Split and Join operate as follows:

- A visit of \( n > 1 \) steps will be split into at least 2 and at most \( n-1 \) sub-visits. QPT will attempt to make all sub-visits equal in length and no longer than two hours.
- Sub-visits may be resized via Longer / Shorter, as described above.
- Adjoining sub-visits may be joined together into a single visit.

Tools > Refresh
The Refresh command synchronizes QPT's internal database snapshot with the current state of the SPDB. Normally you will not need to do this, but if for example you change something in the OT, it won't show up in QPT until you perform a refresh. Refresh performs the following actions:

1. All target information is recalculated for all observations.
2. If an observation was deleted, all associated visits are deleted.
3. If all steps in a visit were executed, the visit is deleted.
4. If some steps were executed, steps are removed from the beginning of the visit.
5. If steps were deleted from the end of the sequence, they are removed from the end of the visit.
6. If step sizes changed, the visit's duration will be adjusted accordingly.

Note that an implicit refresh is performed when a plan file is opened; QPT always reflects the current state of the SPDB.

Tools > Add / Remove Semester
QPT automatically shows observations from the current semester (determined by plan date), as well as plans with rollover status from the previous two semesters. These observations are always available.

It is now possible to import complete additional semesters. This can be useful during the "gray" time in between semesters and perhaps for other special needs. In any case, you can import any extra semesters that exist in the database. You can also remove an added semester as long as none of its observations appear in the schedule.

Help > Update Software...
This command updates QPT to the latest version. You normally only need to do this in response to an email announcing that a new version is available. Note that this doesn't always work correctly; see Running QPT for more information if you have problems.