Change page style: 

Mask-making Software

The current version of the GMOS Mask Making software (GMMPS) is v0.4.1, released in 2014-08-27 for Linux and Mac OS X. This is an interim version to provide support for the new Hamamatsu detectors in GMOS-S. It is not yet fully backwards compatible (see below).

Caution !! VERY IMPORTANT NOTE for GMOS-S users, concerning the Hamamatsu detector upgrade -- PLEASE READ !!

From August 2014 onwards, GMOS-S is offered with the new Hamamatsu detectors. While updating GMMPS to support the new detector system we have identified several problems in the source code concerning the overplotting of the detector gaps and the illuminated field of view. Until a fully backwards compatible version is available:

  • Users of GMOS-N use GMMPS v0.4.1
  • Users of GMOS-S, who have their pre-imaging taken with the NEW detectors, also use GMMPS v0.4.1
  • Users of GMOS-S, who have their pre-imaging taken with the OLD detectors, MUST use GMMPS v0.402
    If you belong to the last category:
    The mask design process is unchanged. However, the OLD detector gaps will be shown instead of the new ones. The latter are wider and a little further separated. The drawing below displays the location of the new gaps with respect to the old ones. Please use this drawing to make sure that your alignment stars do not fall into the gaps.
    Comparison of old and new GMOS-S detector gaps

 

How to get GMMPS

The GMOS Mask Making software is supplied as a gzipped tar file, and is available in compiled form for the following operating systems.

Version 0.4.1 (download)
Version 0.402 (download)

Fedore Core 14 32/64 bit
RedHat Enterprise 5 32/64 bit
Ubuntu 10.04 32/64 bit
Ubuntu 12.04 64 bit
CentOs 6.5 32/64 bit
Mac OS X 64 bits (OSX 10.6-10.9 with Core 2 Duo or newer CPU)

The binaries for Linux and Mac OS X are included in the distribution. The gzipped tar-file is about 30MB, the unpacked software requires 80MB of disk space. Some space can be saved by deleting the bin.PLATFORM and lib.PLATFORM directories which do not support your platform.

Software pre-requisites

  • cfitsio
  • To use GMMPS you must have a working installation of Skycat. Version 3.1.2 is required for 64-bit Linux distributions and OS X (10.7+)
  • You need the latest version of the Gemini IRAF package installed in order to create the input object tables.

Installation

The installation instructions are included with the released software. If the GMMPS binaries provided do not run on your architecture / operating system then you must recompile the GMMPS source code. This requires that you use GNU make, and edit the Makefiles accordingly.

Linux Compatibility Table

Note, to use the compatibility chart... you can give the "GMMPS Platform To Use" name to the "setplatform" or "install" scripts, e.g. for Debian 2.6.8 "install Fedora3".

Reported compatibility of Linux distributions with the GMMPS standard platforms:

Linux Distro GMMPS Platform To Use
Debian 2.6.8 Fedora3
openSUSE 10.2 Fedora3
Redhat Enterprise 2.6 RedHat9
Ubuntu 6.06 (Dapper) Fedora4
Ubuntu 9 (Jaunty Jackalope) Redhat5.5
Ubuntu 12
Fedora 14
Fedora 18
Fedora14
Please submit any other platforms that you know to be compatible via the Gemini Help Desk or any other Gemini Contact ...

Acknowledgments

The Gemini Mask Making Software is built on the ESO/VIMOS Mask Preparation Software, after agreement with European Southern Observatory. The software was modified for GMOS use by Jennifer Dunn (NRC, Canada), Dustin Fennell (Univ. of Victoria) and Craig Allen, Bryan Miller, and Mischa Schirmer (Gemini).